欢迎您来到腾讯云!积分商城

腾讯云腾讯云论坛

 找回密码
 立即注册
快捷导航
搜索
查看: 1726|回复: 3

[已回应] 为什么我的ubuntu安装不上php5

[复制链接]

1

主题

0

好友

60

积分

小白[LV1]

Rank: 1

云币
150
威望
60
发表于 2017-10-16 15:56:41 |显示全部楼层 |未分类
有没有大佬来帮帮小弟

小弟的ubuntu是Ubuntu Server 16.04.1 LTS 64位的
  1. root@VM-62-94-ubuntu:/home/ubuntu# sudo apt-get install php5 libapache2-mod-php5
  2. Reading package lists... Done
  3. Building dependency tree      
  4. Reading state information... Done
  5. Package libapache2-mod-php5 is not available, but is referred to by another package.
  6. This may mean that the package is missing, has been obsoleted, or
  7. is only available from another source

  8. Package php5 is not available, but is referred to by another package.
  9. This may mean that the package is missing, has been obsoleted, or
  10. is only available from another source

  11. E: Package 'php5' has no installation candidate
  12. E: Package 'libapache2-mod-php5' has no installation candidate
  13. root@VM-62-94-ubuntu:/home/ubuntu#
复制代码

38

主题

0

好友

1万

积分

版主

Rank: 7Rank: 7Rank: 7Rank: 7

云币
17332
威望
13440
发表于 2017-10-16 16:14:20 |显示全部楼层
提示在源中没有找到符合条件的包。建议尝试:
  1. sudo apt-get -y update
复制代码
更新了源列表之后,再使用就应该没有问题了。
回复

使用道具 举报

3

主题

0

好友

230

积分

小白[LV1]

Rank: 1

云币
610
威望
230
发表于 2017-10-17 09:39:29 |显示全部楼层
按照我昨天的痛苦的经验:以下说个思路,仅供参考
1:先恶补以下 ubuntu命令
2:找一下服务器里 可供安装的php包
3:如果没有就更新或下载你要的版本的包,搜索度娘的时候带版本号
回复

使用道具 举报

3

主题

0

好友

230

积分

小白[LV1]

Rank: 1

云币
610
威望
230
发表于 2017-10-17 09:42:59 |显示全部楼层
我买的服务器是默认配好 php 5.6的 【CentOS 7.2 64位】给小程序用的服务器。

可以看看我的帖子

centos安装php-pdo,【默认配置好php5.6】



回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

联系我们|腾讯云平台|积分商城|腾讯云官方论坛    

GMT+8, 2019-12-10 12:59 , Processed in 1.144838 second(s), 29 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

回顶部